Header Navigation

Wednesday, August 17, 2016

Spanning Tree Protocol between Cumulus VX and Cisco IOS

1. Overview

The spanning tree algorithm and protocol configure a simply connected active topology from the arbitrarily connected component of a Bridged LAN. - 802.1D - 1998

1.1 System Overview

Because the arbitrarily LAN topology can be trigger looping. With Spanning Tree Protocol (STP), make bridged LAN forward frame in some ports which are held in forwarding state and not through others which are held in blocking state. Port that are in Blocking state do not forward frames until active topology change i.e. Port be put in to forwarding state if components fail, are removed, or are added. 
Bridge that be center of calculation is known as Root Bridge. And this bridge has port that called designated port that has function to forward frame from LAN towards the root, and vice versa. The bridge that connected to this port called Designated Bridge and The ports on this bridge that are in forwarding state are the root port (if that closes to the root) and Designated port (if there any). Port that are not disabled and are neither Root Port nor designated ports do not forward frame onto the LANs to which they connected are called Alternate Port.
Figure 1 - Bridge Active Topology



The stable active topology of a Bridged LAN is determined by:
  1. The unique Bridge Identifier associated with each bridge
  2. The Path cost associated with each Bridge Port
  3. The Port Identifier associated with each Bridge Port
The bridge with highest priority bridge identifier will be root, for convenience and clear calculation highest priority means is lowest numerical value.  Every bridge port in bridged LAN has a root path cost that associated with it. This is sum of path cost for each bridge port receiving frames forwarded from root on the minimal cost path to the bridge. The designated port for each LAN is the Bridge port which the value of the root path cost is the lowest: if two or more ports have the same value of root path cost. Then first the bridge identifier of their bridges and then their port identifiers are used as tie breaker. In the same time, root ports are selected by computation.

Figure 2 - Spanning Tree Topology

1.2 Bridge Protocol Data Unit

Bridge Protocol Data Units (BPDUs) are frames that contain information about the Spanning tree protocol (STP). Switches send BPDUs using a unique MAC address from its origin port and a multicast address as destination MAC (01:80:C2:00:00:00, or 01:00:0C:CC:CC:CD for Per VLAN Spanning Tree). This message contains information that using for build Spanning Tree Topology. BPDU carries Bridge Group Address connected to the LAN on which the frame is transmitted. 
BPDUs are not directly forwarded by Bridges, but they used in calculating its own BPDU to transmit, and may stimulate the transmission. Each configuration BPDU contains, among other parameters, unique identifier of the bridge that transmitting bridge believes to be the root, cost of the path to the root from transmitting port, the identifier of the transmitting bridge, and identifier of the transmitting port. From this information, allow bridge to determine designated port on the LAN which the configuration BPDU was received and determine whether the receiving port should become the root port for the bridge. Bridge port to determine their state (Blocking or Forwarding) is achieved through three basic mechanism:
  1. A bridge that believes itself to be the root (default  for all bridges) originates BPDU messages
  2. A bridge receives the BPDU message on what it decides is its root port conveying better information, passes that information to all the LANS for which it believes itself to be designated bridge
  3. A bridge that receives inferior information, decides its port as Designator port on the LAN to which is attached, then transmit its own information in reply, for all other Bridges attached in to that LAN to hear

1.3 Reconfiguration Effect

When configuration change in each bridge in LAN, it change the topology information. To handle this issue when running spanning tree, each BPDU information has limited lifetime. Every bridge stores the information from designated ports on each LANs to which its ports are connected, and monitor the age of that information.
In normal stable operation, Root Bridge transmits configuration messages periodically to ensure that topology information is not timed out.
If the bridge times out the information held for a port, it will attempt to become designated bridge for LAN to which port is attached, and will transmit protocol information received from the root on its root port on to that LAN.
If the root port of the bridge is timed out, then another port may be selected as the root port. New root port will receives information, and then be calculated by Designated Bridge
If no record information from Root Bridge, then bridge will reconfigure by claiming itself as Root Bridge. If root bridge totally dead, other bridge will also be timing out protocol information, then new information rapidly propagate through the bridge LAN. In other case when cost is changed due reconfigure in bridge port or bridge priority id, neighboring bridge will immediately reply to BPDUs transmitted by aspiring root bridge 
To ensure loss of configuration messages and all bridges in Bridged LAN share a common understanding when information is timed out, the time out value is transmitted in all configuration messages from the root. Beside that the configuration messages adding multiple of the time interval at which these are transmitted by the root bridge
 Transition from one active topology to another, cannot be a sharp due propagation delays in passing protocol information through bridged LAN. Bridge port must wait for the new topology information to propagate throughout the Bridged LAN, frame lifetime of any frames forwarded using old active topology to expire, before forwarding frames.
When the algorithm decides that a port should be put into forwarding state, but first the port put in to a listening state where it waits for protocol information that suggest it should return to blocking state, and for the expiry of a protocol timer what would move to into a learning state. In learning states, forwarding frames is still blocked, but learned station location information is included by learning process in the filtering database. Finally the expiry of a protocol timers moves it in to forwarding state of relayed and learning of station location information are enabled.
The spanning tree algorithm and protocol provides procedure for a bridge that detects a change in active topology to notify the root of change reliably, and for the root subsequently to communicate the change to all the bridges. The bridges the use a shot value to age out dynamic entries in the filtering database for period.
When a bridge is not root change the topology of Bridged LAN, it’s transmit topology change notification BPDU on the LAN which root port is attached. Transmission repeated until the bridges receives acknowledgement for the designated bridge for that LAN. Designated bridge then passes the notification towards root using the same procedure
If the root receive the notification, or changes topology itself, it will set a topology change flag in all configuration messages then transmitting it. All bridge will receive it. While the flag is set, bridges use the value of forwarding delay (interval spent in each of the listening and learning states) to age out dynamic entries. When flag is reset again, bridges revert to using filtering database ageing time

1.4 Port State

The operation of spanning tree algorithm and protocol serves to maintain and change the state of each port in order to meet the requirement placed on the algorithm. This possible ports state and the associated rules relating to the processing of frames are particular to this algorithm and bridge protocol.
The following are specified below for each of the five states – Blocking, Listening, Learning, Forwarding, or Disabled – that port maybe in:
  1. The purpose of state
  2. Whether the forwarding process discard receives frames.
  3. Whether the forwarding process submits forwarded frames for transmission
  4. How the learning process processes received frames
  5. Whether the bridge protocol entity includes the port in it computation of the active topology
  6. Under which condition a port enters and leave the state
Figure 3 - Port States
Below short explanation about each state:
  • Blocking
    A Port in this state does not participate in frame relay, thus preventing frame duplication arising through multiple paths existing in the active topology of the Bridged LAN. The Forwarding Process shall discard received frames. The Learning Process shall not add station location information to the Filtering Database. This state is entered following initialization of the Bridge or from the Disabled State when the Port is enabled through the operation of management. This state can be entered from the Listening, Learning, or Forwarding States through the operation of the Spanning Tree Algorithm and Protocol.
    This state can be left upon expiry of a protocol timer or receipt of a Configuration Message on this or another Port, and the Listening State entered, through the operation of the Spanning Tree Algorithm and Protocol. This state can be left, and the Disabled State entered, through management action.
  • Listening
    The state is entered from the Blocking State when the operation of the Spanning Tree Algorithm and Protocol determines that the Port should participate in frame relay. A Port in this state is preparing to participate in frame relay. Frame relay is temporarily disabled in order to prevent temporary loops, which may occur in a Bridged LAN during the lifetime of this state as the active topology of the Bridged LAN changes. The Learning Process shall not add station location information to the Filtering Database.
    This state can be left upon the expiry of a protocol timer, and the Learning State entered, through the operation of the Spanning Tree Algorithm and Protocol. This state can be left upon receipt of a Bridge Protocol Data Unit on this or another Port, and the Blocking State entered, through the operation of the Spanning Tree Algorithm and Protocol. This state can be left, and the Disabled or the Blocking State entered, through management action.
  • Learning
    This state is entered from the Listening State through the operation of the Spanning Tree Algorithm and Protocol, on the expiry of a protocol timer. Learning is enabled to allow information to be acquired prior to frame relay in order to reduce the number of frames unnecessarily relayed.
    This state can be left upon the expiry of a protocol timer, and the Forwarding State entered, through the operation of the Spanning Tree Algorithm and Protocol. This state can be left upon receipt of a Bridge Protocol Data Unit on this or another Port, and the Blocking State entered, through the operation of the Spanning Tree Algorithm and Protocol. This state can be left, and the Disabled or the Blocking State entered, through management action.
  • Forwarding
    This state is entered from the Learning State through the operation of the Spanning Tree Algorithm and Protocol, on the expiry of a protocol timer. The Forwarding Process can forward receiving frames. It can submit forwarded frames for transmission. The Learning Process shall incorporate station location information into the Filtering Database.
    This state can be left upon receipt of a Bridge Protocol Data Unit on this or another Port, and the Blocking State entered, through the operation of the Spanning Tree Algorithm and Protocol. This state can be left, and the Disabled or the Blocking State entered, through management action.

1.5 RSTP for Rapid Convergence

RSTP is enhancement from STP, this algorithm and protocol further ensures that temporary loop in the active topology do not occurs if the network has to reconfigure in response to the failure, removal, or addition network component, and that erroneous station location information is removed from Filtering Database after reconfiguration.
RSTP provides rapid recovery of connectivity to minimize frame loss. Below the topology that tested in LAB. There are 6 routers. 3 routers as L1 and L2 router and 3 router as L1 router. New root port delay used by a Designated Port attached to a shared media LAN is long enough for other Bridges attached to that LAN to receive and act on transmitted messages, but is independent of the overall network size. If all the LANs in a network are point-to-point, RSTP timers define worst-case delays that only occur if protocol messages are lost or rate transmission limits are exceeded and designated port attached point-to-point LANs do not need to waiting timer to expire to transition forwarding state the forwarding transition.
A Bridge Port attached to a LAN that has no other Bridges attached to it may be administratively configured as an Edge Port. RSTP monitors the LAN to ensure that no other Bridges are connected, and may be configured to automatically detect an Edge Port. Each Edge Port transitions directly to the Forwarding Port State, since there is no possibility of it participating in a loop.

1.6 Path Cost Parameter

Path cost using for computation for alternate port determination, port that determine as alternate port will be in blocking state. Assigning Path Cost in the STP calculations, each switch must establish a single path to the root. By doing this, all loops are eliminated. Three values are used in the STP port calculations:
  • Port priority (has a default value but is configurable)
  • Per port cost (the default value is dependent on bandwidth but is configurable)
  • Port MAC address
Each port on a bridge/switch has a path cost value assigned automatically, depending on the bandwidth. The accumulated path cost from the bridge to the root determines the total cost to reach the root. The default path costs for various link types are shown in Table.
Table 1 - STP Cost Table

2. Test LAB

2.1 Topology and Interface Information

Figure 4 - Main Topology
Below the loopback/system IP information:
Some option, that used in LAB test are:

  • Root Bridge is configurable on SW-SP2-CMS 
  • STP using PVSTP method

In table of, there are several information about bridge MAC (acting as bridge id), 
Table 2 - Switch Information
And interface information and default cost installed on it:
Table 3 - Switch Interface Peering and Cost Information

2.2 LAB Testing Process 

2.2.1 Default Configuration and Validation

Below the default configuration
Configuration under SW-SP1-CSC
Current configuration : 1386 bytes
!
! Last configuration change at 18:43:07 UTC Thu Jun 30 2016
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW-LF1-CSC
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ipv6 cef
ipv6 multicast rpf use-bgp
!
ip cef
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet1/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet1/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet1/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 shutdown
 duplex auto
!
interface Ethernet1/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 shutdown
 duplex auto
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
end

Configuration under SW-LF1-CSC
Current configuration : 1386 bytes
!
! Last configuration change at 18:43:07 UTC Thu Jun 30 2016
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW-LF1-CSC
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ipv6 cef
ipv6 multicast rpf use-bgp
!
ip cef
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet1/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet1/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet1/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 shutdown
 duplex auto
!
interface Ethernet1/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 shutdown
 duplex auto
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
end

Configuration under SW-LF2-CSC
Current configuration : 1274 bytes
!
! Last configuration change at 18:51:13 UTC Thu Jun 30 2016
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW-LF2-CSC
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
ip cef
!
!
no ipv6 cef
ipv6 multicast rpf use-bgp
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet1/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet1/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet1/2
 shutdown
 duplex auto
!
interface Ethernet1/3
 shutdown
 duplex auto
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
end

Configuration under SW-LF3-CSC
urrent configuration : 1396 bytes
!
! Last configuration change at 18:52:13 UTC Thu Jun 30 2016
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW-LF3-CSC
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
ip cef
!
!
no ipv6 cef
ipv6 multicast rpf use-bgp
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet1/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet1/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet1/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 shutdown
 duplex auto
!
interface Ethernet1/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 shutdown
 duplex auto
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
end

Configuration under SW-TOR1-CSC
Current configuration : 1455 bytes
!
! Last configuration change at 18:52:38 UTC Thu Jun 30 2016
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW-TOR1-CSC
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ipv6 cef
ipv6 multicast rpf use-bgp
!
ip cef
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/3
 switchport access vlan 100
 switchport trunk encapsulation dot1q
 switchport mode access
 duplex auto
!
interface Ethernet1/0
 switchport access vlan 200
 switchport trunk encapsulation dot1q
 switchport mode access
 duplex auto
!
interface Ethernet1/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 shutdown
 duplex auto
!
interface Ethernet1/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 shutdown
 duplex auto
!
interface Ethernet1/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 shutdown
 duplex auto
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
end

Configuration under SW-TOR2-CMS
root@SW-TOR2-CMS:/home/cumulus# cat /etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*.intf

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 192.168.10.18
        netmask 255.255.255.0
        gateway 192.168.10.1

auto swp1
iface swp1 

auto swp2
iface swp2 

auto swp3
iface swp3

auto swp4
iface swp4

auto swp5
iface swp5


auto br-tor2
iface br-tor2
        bridge-ports swp1 swp2 swp3
        bridge-stp on

auto br-tor2-100
iface br-tor2-100
        bridge-ports swp1.100 swp2.100 swp3.100 swp4
        bridge-stp on

auto br-tor2-200
iface br-tor2-200
        bridge-ports swp1.200 swp2.200 swp3.200 swp5     
        bridge-stp on
root@SW-TOR2-CMS:/home/cumulus#

Configuration under SW-TOR3-CSC
Current configuration : 1455 bytes
!
! Last configuration change at 18:54:41 UTC Thu Jun 30 2016
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname SW-TOR3-CSC
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ipv6 cef
ipv6 multicast rpf use-bgp
!
ip cef
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
!
interface Ethernet0/3
 switchport access vlan 100
 switchport trunk encapsulation dot1q
 switchport mode access
 duplex auto
!
interface Ethernet1/0
 switchport access vlan 200
 switchport trunk encapsulation dot1q
 switchport mode access
 duplex auto
!
interface Ethernet1/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 shutdown
 duplex auto
!
interface Ethernet1/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 shutdown
 duplex auto
!
interface Ethernet1/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 shutdown
 duplex auto
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
end

Configuration under SW-TOR4-CMS
root@SW-TOR4-CMS:/home/cumulus#  cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*.intf

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
        address 192.168.10.19
        netmask 255.255.255.0
        gateway 192.168.10.1

auto swp1 
iface swp1

auto swp2
iface swp2

auto swp3
iface swp3

auto swp4
iface swp4

auto swp5
iface swp5

auto br-tor4
iface br-tor4
        bridge-ports swp1 swp2 swp3
        bridge-stp on

auto br-tor4-100
iface br-tor4-100
        bridge-ports swp1.100 swp2.100 swp3.100 swp4     
        bridge-stp on

auto br-tor4-200
iface br-tor4-200
        bridge-ports swp1.200 swp2.200 swp3.200 swp5
        bridge-stp on
root@SW-TOR4-CMS:/home/cumulus#

Based configuration above, the SW-SP2-CMS acting as Root Bridge. The switch then compute the cost to determine port role and state. For each VLAN. Below verifying configuration there are information about cost, port role for each VLAN in Cumulus VX and Cisco IOL L2 switch

Verification under SW-SP1-CSC
SW-SP1-CSC#sh spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        100
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     aabb.cc00.0100
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/1               Root FWD 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.33   Shr


VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        100
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0100
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/1               Root FWD 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.33   Shr

VLAN0200
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        100
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     aabb.cc00.0100
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/1               Root FWD 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.33   Shr

Verification under SW-SP2-CMS
root@SW-SP2-CMS:/home/cumulus# mstpctl showbridge br-sp2
br-sp2 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:02:00:02
  designated root 8.000.50:00:00:02:00:02
  regional root   8.000.50:00:00:02:00:02
  root port       none
  path cost     0          internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 6078s
  topology change count      52
  topology change            no
  topology change port       swp5
  last topology change port  swp4
root@SW-SP2-CMS:/home/cumulus# mstpctl showport br-sp2
   swp2  8.001 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.001 Desg
   swp3  8.002 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.002 Desg
   swp4  8.003 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.003 Desg
   swp5  8.004 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.004 Desg  

root@SW-SP2-CMS:/home/cumulus# mstpctl showbridge br-sp2-100
br-sp2-100 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:02:00:02
  designated root 8.000.50:00:00:02:00:02
  regional root   8.000.50:00:00:02:00:02
  root port       none
  path cost     0          internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 6058s
  topology change count      5
  topology change            no
  topology change port       swp5.100
  last topology change port  swp4.100
root@SW-SP2-CMS:/home/cumulus# mstpctl showport br-sp2-100
   swp2.100 8.004 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.004 Desg
   swp3.100 8.002 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.002 Desg
   swp4.100 8.001 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.001 Desg
   swp5.100 8.003 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.003 Desg
  
root@SW-SP2-CMS:/home/cumulus# mstpctl showbridge br-sp2-200
br-sp2-200 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:02:00:02
  designated root 8.000.50:00:00:02:00:02
  regional root   8.000.50:00:00:02:00:02
  root port       none
  path cost     0          internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 6061s
  topology change count      5
  topology change            no
  topology change port       swp5.200
  last topology change port  swp4.200
root@SW-SP2-CMS:/home/cumulus# mstpctl showport br-sp2-200
   swp2.200 8.003 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.003 Desg
   swp3.200 8.001 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.001 Desg
   swp4.200 8.002 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.002 Desg
   swp5.200 8.004 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.004 Desg
root@SW-SP2-CMS:/home/cumulus#

Verification under SW-LF1-CSC
SW-LF1-CSC#sh spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        100
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     aabb.cc00.0300
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Altn BLK 100       128.1    Shr
Et0/1               Root FWD 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.33   Shr
Et1/1               Desg FWD 100       128.34   Shr

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        100
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0300
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Altn BLK 100       128.1    Shr
Et0/1               Root FWD 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.33   Shr
Et1/1               Desg FWD 100       128.34   Shr

VLAN0200
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        100
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     aabb.cc00.0300
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Altn BLK 100       128.1    Shr
Et0/1               Root FWD 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.33   Shr
Et1/1               Desg FWD 100       128.34   Shr

Verification under SW-LF2-CSC
SW-LF2-CSC#sh spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        100
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     aabb.cc00.0400
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Altn BLK 100       128.1    Shr
Et0/1               Root FWD 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.5    Shr
Et1/1               Desg FWD 100       128.6    Shr

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        100
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0400
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Altn BLK 100       128.1    Shr
Et0/1               Root FWD 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.5    Shr
Et1/1               Desg FWD 100       128.6    Shr

VLAN0200
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        100
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     aabb.cc00.0400
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Altn BLK 100       128.1    Shr
Et0/1               Root FWD 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.5    Shr
Et1/1               Desg FWD 100       128.6    Shr

Verification under SW-LF3-CSC
SW-LF3-CSC#sh spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        100
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     aabb.cc00.0500
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Altn BLK 100       128.1    Shr
Et0/1               Root FWD 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.5    Shr
Et1/1               Desg FWD 100       128.6    Shr

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        100
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0500
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Altn BLK 100       128.1    Shr
Et0/1               Root FWD 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.5    Shr
Et1/1               Desg FWD 100       128.6    Shr

VLAN0200
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        100
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     aabb.cc00.0500
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Altn BLK 100       128.1    Shr
Et0/1               Root FWD 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.5    Shr
Et1/1               Desg FWD 100       128.6    Shr

Verification under SW-TOR1-CSC
SW-TOR1-CSC#sh spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        200
             Port        1 (Ethernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     aabb.cc00.0600
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr
Et0/1               Altn BLK 100       128.2    Shr
Et0/2               Altn BLK 100       128.3    Shr

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        200
             Port        1 (Ethernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0600
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr
Et0/1               Altn BLK 100       128.2    Shr
Et0/2               Altn BLK 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr

VLAN0200
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        200
             Port        1 (Ethernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     aabb.cc00.0600
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr
Et0/1               Altn BLK 100       128.2    Shr
Et0/2               Altn BLK 100       128.3    Shr
Et1/0               Desg FWD 100       128.33   Shr

Verification under SW-TOR2-CMS
root@SW-TOR2-CMS:/home/cumulus# mstpctl showbridge
br-tor2 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:07:00:01
  designated root 8.000.50:00:00:02:00:02
  regional root   8.000.50:00:00:07:00:01
  root port       swp1 (#3)
  path cost     2000100    internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 79411s
  topology change count      27
  topology change            no
  topology change port       swp1
  last topology change port  swp2
root@SW-TOR2-CMS:/home/cumulus# mstpctl showport br-tor2
   swp1  8.003 forw 8.000.50:00:00:02:00:02 8.001.AA:BB:CC:00:03:00 8.004 Root
   swp2  8.001 disc 8.000.50:00:00:02:00:02 8.001.AA:BB:CC:00:04:00 8.004 Altn
   swp3  8.002 disc 8.000.50:00:00:02:00:02 8.001.AA:BB:CC:00:05:00 8.004 Altn
   
br-tor2-100 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:07:00:01
  designated root 8.000.50:00:00:02:00:02
  regional root   8.000.50:00:00:07:00:01
  root port       swp1.100 (#1)
  path cost     2000100    internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 6574s
  topology change count      2
  topology change            no
  topology change port       swp4
  last topology change port  swp1.100
root@SW-TOR2-CMS:/home/cumulus# mstpctl showport br-tor2-100
   swp1.100 8.001 forw 8.000.50:00:00:02:00:02 8.064.AA:BB:CC:00:03:00 8.004 Root
   swp2.100 8.004 disc 8.000.50:00:00:02:00:02 8.064.AA:BB:CC:00:04:00 8.004 Altn
   swp3.100 8.002 disc 8.000.50:00:00:02:00:02 8.064.AA:BB:CC:00:05:00 8.004 Altn
 E swp4  8.003 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:07:00:01 8.003 Desg
 
br-tor2-200 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:07:00:01
  designated root 8.000.50:00:00:02:00:02
  regional root   8.000.50:00:00:07:00:01
  root port       swp1.200 (#2)
  path cost     2000100    internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 6474s
  topology change count      1
  topology change            no
  topology change port       swp5
  last topology change port  swp3.200
root@SW-TOR2-CMS:/home/cumulus# 
root@SW-TOR2-CMS:/home/cumulus# mstpctl showport br-tor2-200
   swp1.200 8.002 forw 8.000.50:00:00:02:00:02 8.0C8.AA:BB:CC:00:03:00 8.004 Root
   swp2.200 8.003 disc 8.000.50:00:00:02:00:02 8.0C8.AA:BB:CC:00:04:00 8.004 Altn
   swp3.200 8.001 disc 8.000.50:00:00:02:00:02 8.0C8.AA:BB:CC:00:05:00 8.004 Altn
 E swp5  8.004 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:07:00:01 8.004 Desg

Verification under SW-TOR3-CSC
SW-TOR3-CSC#sh spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        200
             Port        1 (Ethernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     aabb.cc00.0800
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr
Et0/1               Altn BLK 100       128.2    Shr
Et0/2               Altn BLK 100       128.3    Shr

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        200
             Port        1 (Ethernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0800
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr
Et0/1               Altn BLK 100       128.2    Shr
Et0/2               Altn BLK 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr

VLAN0200
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        200
             Port        1 (Ethernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     aabb.cc00.0800
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr
Et0/1               Altn BLK 100       128.2    Shr
Et0/2               Altn BLK 100       128.3    Shr
Et1/0               Desg FWD 100       128.33   Shr

Verification under SW-TOR4-CMS
root@SW-TOR4-CMS:/home/cumulus# mstpctl showbridge br-tor4
br-tor4 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:09:00:01
  designated root 8.000.50:00:00:02:00:02
  regional root   8.000.50:00:00:09:00:01
  root port       swp1 (#3)
  path cost     2000100    internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 83297s
  topology change count      18
  topology change            no
  topology change port       swp1
  last topology change port  swp2
root@SW-TOR4-CMS:/home/cumulus# mstpctl showport br-tor4
   swp1  8.003 forw 8.000.50:00:00:02:00:02 8.001.AA:BB:CC:00:03:00 8.022 Root
   swp2  8.001 disc 8.000.50:00:00:02:00:02 8.001.AA:BB:CC:00:04:00 8.006 Altn
   swp3  8.002 disc 8.000.50:00:00:02:00:02 8.001.AA:BB:CC:00:05:00 8.006 Altn
   
root@SW-TOR4-CMS:/home/cumulus# mstpctl showbridge br-tor4-100
br-tor4-100 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:09:00:01
  designated root 8.000.50:00:00:02:00:02
  regional root   8.000.50:00:00:09:00:01
  root port       swp1.100 (#1)
  path cost     2000100    internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 8763s
  topology change count      1
  topology change            no
  topology change port       swp4
  last topology change port  swp1.100
root@SW-TOR4-CMS:/home/cumulus# mstpctl showport br-tor4-100
   swp1.100 8.001 forw 8.000.50:00:00:02:00:02 8.064.AA:BB:CC:00:03:00 8.022 Root
   swp2.100 8.004 disc 8.000.50:00:00:02:00:02 8.064.AA:BB:CC:00:04:00 8.006 Altn
   swp3.100 8.002 disc 8.000.50:00:00:02:00:02 8.064.AA:BB:CC:00:05:00 8.006 Altn
 E swp4  8.003 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:09:00:01 8.003 Desg

 root@SW-TOR4-CMS:/home/cumulus# mstpctl showbridge br-tor4-200
br-tor4-200 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:09:00:01
  designated root 8.000.50:00:00:02:00:02
  regional root   8.000.50:00:00:09:00:01
  root port       swp1.200 (#2)
  path cost     2000100    internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 8768s
  topology change count      1
  topology change            no
  topology change port       swp5
  last topology change port  swp1.200
root@SW-TOR4-CMS:/home/cumulus# mstpctl showport br-tor4-200
   swp1.200 8.002 forw 8.000.50:00:00:02:00:02 8.0C8.AA:BB:CC:00:03:00 8.022 Root
   swp2.200 8.003 disc 8.000.50:00:00:02:00:02 8.0C8.AA:BB:CC:00:04:00 8.006 Altn
   swp3.200 8.001 disc 8.000.50:00:00:02:00:02 8.0C8.AA:BB:CC:00:05:00 8.006 Altn
 E swp5  8.004 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:09:00:01 8.004 Desg
root@SW-TOR4-CMS:/home/cumulus#

From the verification information, the traffic flow will describe like figure 8, where SW-SP2-CMS acting as Root Bridge and port’s role and state was determined:
 Figure 5 - Flow Traffic for default configuration

2.2.2 Use-Case 1

Use-Case 1 is proposed to proof the function of bridge priority. From this lab I try to lowering the Bridge Priority in SW-SP1-CSC to make it acting as Root Bridge.  The limitation of this test lab. I just test for one VLAN (VLAN 100). Bridge Priority is changed to 4096, it makes SW-SP1-CSC acting as Root Bridge

Configuration under SW-SP1-CSC
SW-SP1-CSC(config)#spanning-tree vlan 100 priority 4096
SW-SP1-CSC(config)#

Below verifying information for STP that VLAN 100 use, which SW-SP1-CSC acting as Root Bridge,

Verification under SW-SP1-CSC
SW-SP1-CSC#sh spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    4196
             Address     aabb.cc00.0100
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    4196   (priority 4096 sys-id-ext 100)
             Address     aabb.cc00.0100
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/1               Desg FWD 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.33   Shr

Verification under SW-SP2-CMS
root@SW-SP2-CMS:/home/cumulus# mstpctl showbridge br-sp2-100
br-sp2-100 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:02:00:02
  designated root 1.064.AA:BB:CC:00:01:00
  regional root   8.000.50:00:00:02:00:02
  root port       swp2.100 (#4)
  path cost     200000     internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 140s
  topology change count      12
  topology change            no
  topology change port       swp5.100
  last topology change port  swp4.100
root@SW-SP2-CMS:/home/cumulus# mstpctl showport br-sp2-100
   swp2.100 8.004 forw 1.064.AA:BB:CC:00:01:00 1.064.AA:BB:CC:00:01:00 8.002 Root
   swp3.100 8.002 disc 1.064.AA:BB:CC:00:01:00 8.064.AA:BB:CC:00:03:00 8.002 Altn
   swp4.100 8.001 disc 1.064.AA:BB:CC:00:01:00 8.064.AA:BB:CC:00:04:00 8.002 Altn
   swp5.100 8.003 disc 1.064.AA:BB:CC:00:01:00 8.064.AA:BB:CC:00:05:00 8.002 Altn

Verification under SW-LF1-CSC
SW-LF1-CSC#sh spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    4196
             Address     aabb.cc00.0100
             Cost        100
             Port        1 (Ethernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0300
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr
Et0/1               Desg FWD 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.33   Shr
Et1/1               Desg FWD 100       128.34   Shr

Verification under SW-LF2-CSC
SW-LF2-CSC#sh spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    4196
             Address     aabb.cc00.0100
             Cost        100
             Port        1 (Ethernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0400
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr
Et0/1               Desg FWD 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.5    Shr
Et1/1               Desg FWD 100       128.6    Shr

Verification under SW-LF3-CSC
SW-LF3-CSC#sh spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    4196
             Address     aabb.cc00.0100
             Cost        100
             Port        1 (Ethernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0500
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr
Et0/1               Desg FWD 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.5    Shr
Et1/1               Desg FWD 100       128.6    Shr

Verification under SW-TOR1-CSC
SW-TOR1-CSC#sh spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    4196
             Address     aabb.cc00.0100
             Cost        200
             Port        1 (Ethernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0600
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr
Et0/1               Altn BLK 100       128.2    Shr
Et0/2               Altn BLK 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr

Verification under SW-TOR2-CMS
root@SW-TOR2-CMS:/home/cumulus# mstpctl showbridge br-tor2-100
br-tor2-100 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:07:00:01
  designated root 1.064.AA:BB:CC:00:01:00
  regional root   8.000.50:00:00:07:00:01
  root port       swp1.100 (#1)
  path cost     2000100    internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 785s
  topology change count      3
  topology change            no
  topology change port       swp1.100
  last topology change port  swp3.100
root@SW-TOR2-CMS:/home/cumulus# mstpctl showport br-tor2-100
   swp1.100 8.001 forw 1.064.AA:BB:CC:00:01:00 8.064.AA:BB:CC:00:03:00 8.004 Root
   swp2.100 8.004 disc 1.064.AA:BB:CC:00:01:00 8.064.AA:BB:CC:00:04:00 8.004 Altn
   swp3.100 8.002 disc 1.064.AA:BB:CC:00:01:00 8.064.AA:BB:CC:00:05:00 8.004 Altn
 E swp4  8.003 forw 1.064.AA:BB:CC:00:01:00 8.000.50:00:00:07:00:01 8.003 Desg
root@SW-TOR2-CMS:/home/cumulus#

Verification under SW-TOR3-CSC
SW-TOR3-CSC#sh spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    4196
             Address     aabb.cc00.0100
             Cost        200
             Port        1 (Ethernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0800
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr
Et0/1               Altn BLK 100       128.2    Shr
Et0/2               Altn BLK 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr

Verification under SW-TOR4-CMS
root@SW-TOR4-CMS:/home/cumulus# mstpctl showbridge br-tor4-100
br-tor4-100 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:09:00:01
  designated root 1.064.AA:BB:CC:00:01:00
  regional root   8.000.50:00:00:09:00:01
  root port       swp1.100 (#1)
  path cost     2000100    internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 12847s
  topology change count      1
  topology change            no
  topology change port       swp4
  last topology change port  swp1.100
root@SW-TOR4-CMS:/home/cumulus# mstpctl showport br-tor4-100
   swp1.100 8.001 forw 1.064.AA:BB:CC:00:01:00 8.064.AA:BB:CC:00:03:00 8.022 Root
   swp2.100 8.004 disc 1.064.AA:BB:CC:00:01:00 8.064.AA:BB:CC:00:04:00 8.006 Altn
   swp3.100 8.002 disc 1.064.AA:BB:CC:00:01:00 8.064.AA:BB:CC:00:05:00 8.006 Altn
 E swp4  8.003 forw 1.064.AA:BB:CC:00:01:00 8.000.50:00:00:09:00:01 8.003 Desg
root@SW-TOR4-CMS:/home/cumulus#

Figure 9 describe how flow traffic changes because Root Bridge changed.
Figure 5 - Traffic Flow Change After Change Root Bridge for VLAN 100

2.2.3 Use-Case 2

This part is really interesting, this use case proof how cost influence your flow traffic. With Per VLAN STP (PVSTP), I can drive each VLAN traffic meet our requirement path. This lab I configure cost path to create VLAN 100 and VLAN 200 flow, where each VLAN has their own path. Cost information I describe in figure
Table 4 - VLAN port cost
Default cost in each port depend on port speed (see Figure 4) and the port speed is 10 Mbps in each switch. I just convert the table to configuration, like below. Please you note, in TOR 3 we don’t need to configure because it’s default configuration:

Configuration under SW-SP1-CSC
interface Ethernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
 spanning-tree vlan 100 cost 50
 spanning-tree vlan 200 cost 10
!

Configuration under SW-SP2-CMS
auto br-sp2-100
iface br-sp2-100                     
        bridge-ports swp2.100 swp3.100 swp4.100 swp5.100
        bridge-stp on
        mstpctl-portpathcost swp2.100=100 swp3.100=100 swp4.100=100 swp5.100=100

auto br-sp2-200
iface br-sp2-200
        bridge-ports swp2.200 swp3.200 swp4.200 swp5.200
        bridge-stp on
        mstpctl-portpathcost swp2.200=10 swp3.200=100 swp4.200=100 swp5.200=100

Configuration under SW-LF1-CSC
!
interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
 spanning-tree vlan 200 cost 10
!
interface Ethernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
 spanning-tree vlan 100 cost 250
!

Configuration under SW-LF2-CSC
!
interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
 spanning-tree vlan 200 cost 10
!

Configuration under SW-LF3-CSC
!
interface Ethernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
 spanning-tree vlan 100 cost 200
 spanning-tree vlan 200 cost 10
!

Configuration under SW-TOR1-CSC
!
interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
 spanning-tree vlan 200 cost 150
!
interface Ethernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
 spanning-tree vlan 100 cost 150
!
interface Ethernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 duplex auto
 spanning-tree vlan 100 cost 150
 spanning-tree vlan 200 cost 200
!

Configuration under SW-TOR2-CMS
auto br-tor2-100
iface br-tor2-100
        bridge-ports swp1.100 swp2.100 swp3.100 swp4
        bridge-stp on
        mstpctl-portpathcost swp1.100=150 swp2.100=170 swp3.100=100 

auto br-tor2-200
iface br-tor2-200
        bridge-ports swp1.200 swp2.200 swp3.200 swp5     
        bridge-stp on
        mstpctl-portpathcost swp1.200=10 swp2.200=150 swp3.200=150

Configuration under SW-TOR4-CMS
auto br-tor4-100
iface br-tor4-100
        bridge-ports swp1.100 swp2.100 swp3.100 swp4     
        bridge-stp on
        mstpctl-portpathcost swp1.100=100 swp2.100=100 swp3.100=100

auto br-tor4-200
iface br-tor4-200
        bridge-ports swp1.200 swp2.200 swp3.200 swp5
        bridge-stp on
        mstpctl-portpathcost swp1.200=100 swp2.200=100 swp3.200=10

Let’s see, how this configuration can influence port role and port state in each switch.

Verification under SW-SP1-CSC
SW-SP1-CSC#sh spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        50
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0100
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Desg FWD 100       128.1    Shr
Et0/1               Root FWD 50        128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.33   Shr
Et1/1               Desg FWD 100       128.34   Shr
Et1/2               Desg FWD 100       128.35   Shr

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------

Et1/3               Desg FWD 100       128.36   Shr

SW-SP1-CSC#
SW-SP1-CSC#sh spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        10
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     aabb.cc00.0100
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Desg FWD 100       128.1    Shr
Et0/1               Root FWD 10        128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.33   Shr
Et1/1               Desg FWD 100       128.34   Shr
Et1/2               Desg FWD 100       128.35   Shr

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------

Et1/3               Desg FWD 100       128.36   Shr

SW-SP1-CSC#

Verification under SW-SP2-CMS
root@SW-SP2-CMS:/home/cumulus# mstpctl showbridge br-sp2-100
br-sp2-100 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:02:00:02
  designated root 8.000.50:00:00:02:00:02
  regional root   8.000.50:00:00:02:00:02
  root port       none
  path cost     0          internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 161868s
  topology change count      30
  topology change            no
  topology change port       swp5.100
  last topology change port  swp4.100
root@SW-SP2-CMS:/home/cumulus# mstpctl showport br-sp2-100
   swp2.100 8.004 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.004 Desg
   swp3.100 8.002 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.002 Desg
   swp4.100 8.001 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.001 Desg
   swp5.100 8.003 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.003 Desg
root@SW-SP2-CMS:/home/cumulus# 

root@SW-SP2-CMS:/home/cumulus# mstpctl showbridge br-sp2-200
br-sp2-200 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:02:00:02
  designated root 8.000.50:00:00:02:00:02
  regional root   8.000.50:00:00:02:00:02
  root port       none
  path cost     0          internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 524s
  topology change count      26
  topology change            no
  topology change port       swp2.200
  last topology change port  swp5.200
root@SW-SP2-CMS:/home/cumulus# mstpctl showport br-sp2-200
   swp2.200 8.003 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.003 Desg
   swp3.200 8.001 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.001 Desg
   swp4.200 8.002 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.002 Desg
   swp5.200 8.004 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:02:00:02 8.004 Desg
root@SW-SP2-CMS:/home/cumulus#

Verification under SW-LF1-CSC
SW-LF1-CSC#sh spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        150
             Port        1 (Ethernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0300
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr
Et0/1               Altn BLK 250       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.33   Shr
Et1/1               Desg FWD 100       128.34   Shr
Et1/2               Desg FWD 100       128.35   Shr

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------

Et1/3               Desg FWD 100       128.36   Shr


SW-LF1-CSC#
SW-LF1-CSC#sh spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        20
             Port        1 (Ethernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     aabb.cc00.0300
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 10        128.1    Shr
Et0/1               Altn BLK 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.33   Shr
Et1/1               Altn BLK 100       128.34   Shr
Et1/2               Desg FWD 100       128.35   Shr

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------

Et1/3               Desg FWD 100       128.36   Shr

SW-LF1-CSC#

Verification under SW-LF2-CSC
SW-LF2-CSC#sh spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        100
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0400
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Altn BLK 100       128.1    Shr
Et0/1               Root FWD 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.5    Shr
Et1/1               Desg FWD 100       128.6    Shr


SW-LF2-CSC#
SW-LF2-CSC#sh spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        20
             Port        1 (Ethernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     aabb.cc00.0400
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 10        128.1    Shr
Et0/1               Altn BLK 100       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.5    Shr
Et1/1               Altn BLK 100       128.6    Shr


SW-LF2-CSC#

Verification under SW-LF3-CSC
SW-LF3-CSC#sh spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        150
             Port        1 (Ethernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0500
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr
Et0/1               Altn BLK 200       128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.5    Shr
Et1/1               Desg FWD 100       128.6    Shr
Et1/2               Desg FWD 100       128.7    Shr

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------

Et1/3               Desg FWD 100       128.8    Shr


SW-LF3-CSC#
SW-LF3-CSC#sh spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        10
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     aabb.cc00.0500
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Altn BLK 100       128.1    Shr
Et0/1               Root FWD 10        128.2    Shr
Et0/2               Desg FWD 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/0               Desg FWD 100       128.5    Shr
Et1/1               Desg FWD 100       128.6    Shr
Et1/2               Desg FWD 100       128.7    Shr

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------

Et1/3               Desg FWD 100       128.8    Shr


SW-LF3-CSC#

Verification under SW-TOR1-CSC
SW-TOR1-CSC#sh spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        250
             Port        1 (Ethernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0600
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr
Et0/1               Altn BLK 150       128.2    Shr
Et0/2               Altn BLK 150       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/1               Desg FWD 100       128.34   Shr
Et1/2               Desg FWD 100       128.35   Shr
Et1/3               Desg FWD 100       128.36   Shr


SW-TOR1-CSC#
SW-TOR1-CSC#sh spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        120
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     aabb.cc00.0600
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Altn BLK 150       128.1    Shr
Et0/1               Root FWD 100       128.2    Shr
Et0/2               Altn BLK 200       128.3    Shr
Et1/0               Desg FWD 100       128.33   Shr
Et1/1               Desg FWD 100       128.34   Shr
Et1/2               Desg FWD 100       128.35   Shr
Et1/3               Desg FWD 100       128.36   Shr


SW-TOR1-CSC#

Verification under SW-TOR2-CMS
root@SW-TOR2-CMS:/home/cumulus# mstpctl showbridge br-tor2-100
br-tor2-100 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:07:00:01
  designated root 8.000.50:00:00:02:00:02
  regional root   8.000.50:00:00:07:00:01
  root port       swp3.100 (#2)
  path cost     250        internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 161937s
  topology change count      21
  topology change            no
  topology change port       swp3.100
  last topology change port  swp2.100
root@SW-TOR2-CMS:/home/cumulus# mstpctl showport br-tor2-100
   swp1.100 8.001 disc 8.000.50:00:00:02:00:02 8.064.AA:BB:CC:00:03:00 8.004 Altn
   swp2.100 8.004 disc 8.000.50:00:00:02:00:02 8.064.AA:BB:CC:00:04:00 8.004 Altn
   swp3.100 8.002 forw 8.000.50:00:00:02:00:02 8.064.AA:BB:CC:00:05:00 8.004 Root
 E swp4  8.003 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:07:00:01 8.003 Desg
root@SW-TOR2-CMS:/home/cumulus# 

root@SW-TOR2-CMS:/home/cumulus# mstpctl showbridge br-tor2-200
br-tor2-200 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:07:00:01
  designated root 8.000.50:00:00:02:00:02
  regional root   8.000.50:00:00:07:00:01
  root port       swp1.200 (#2)
  path cost     110        internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 529s
  topology change count      11
  topology change            no
  topology change port       swp1.200
  last topology change port  swp3.200
root@SW-TOR2-CMS:/home/cumulus# mstpctl showport br-tor2-200
   swp1.200 8.002 forw 8.000.50:00:00:02:00:02 8.0C8.AA:BB:CC:00:03:00 8.004 Root
   swp2.200 8.003 disc 8.000.50:00:00:02:00:02 8.0C8.AA:BB:CC:00:04:00 8.004 Altn
   swp3.200 8.001 disc 8.000.50:00:00:02:00:02 8.0C8.AA:BB:CC:00:05:00 8.004 Altn
 E swp5  8.004 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:07:00:01 8.004 Desg
root@SW-TOR2-CMS:/home/cumulus#

Verification under SW-TOR3-CSC
SW-TOR3-CSC#sh spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        200
             Port        2 (Ethernet0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     aabb.cc00.0800
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Altn BLK 100       128.1    Shr
Et0/1               Root FWD 100       128.2    Shr
Et0/2               Altn BLK 100       128.3    Shr
Et0/3               Desg FWD 100       128.4    Shr
Et1/1               Desg FWD 100       128.34   Shr
Et1/2               Desg FWD 100       128.35   Shr
Et1/3               Desg FWD 100       128.36   Shr


SW-TOR3-CSC#
SW-TOR3-CSC#sh spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol ieee
  Root ID    Priority    32768
             Address     5000.0002.0002
             Cost        110
             Port        3 (Ethernet0/2)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     aabb.cc00.0800
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Altn BLK 100       128.1    Shr
Et0/1               Altn BLK 100       128.2    Shr
Et0/2               Root FWD 100       128.3    Shr
Et1/0               Desg FWD 100       128.33   Shr
Et1/1               Desg FWD 100       128.34   Shr
Et1/2               Desg FWD 100       128.35   Shr
Et1/3               Desg FWD 100       128.36   Shr


SW-TOR3-CSC#

Verification under SW-TOR4-CMS
root@SW-TOR4-CMS:/home/cumulus# mstpctl showbridge br-tor4-100
br-tor4-100 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:09:00:01
  designated root 8.000.50:00:00:02:00:02
  regional root   8.000.50:00:00:09:00:01
  root port       swp2.100 (#4)
  path cost     200        internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 163632s
  topology change count      12
  topology change            no
  topology change port       swp2.100
  last topology change port  swp1.100
root@SW-TOR4-CMS:/home/cumulus# mstpctl showport br-tor4-100
   swp1.100 8.001 disc 8.000.50:00:00:02:00:02 8.064.AA:BB:CC:00:03:00 8.022 Altn
   swp2.100 8.004 forw 8.000.50:00:00:02:00:02 8.064.AA:BB:CC:00:04:00 8.006 Root
   swp3.100 8.002 disc 8.000.50:00:00:02:00:02 8.064.AA:BB:CC:00:05:00 8.006 Altn
 E swp4  8.003 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:09:00:01 8.003 Desg
root@SW-TOR4-CMS:/home/cumulus#

root@SW-TOR4-CMS:/home/cumulus# mstpctl showbridge br-tor4-200
br-tor4-200 CIST info
  enabled         yes
  bridge id       8.000.50:00:00:09:00:01
  designated root 8.000.50:00:00:02:00:02
  regional root   8.000.50:00:00:09:00:01
  root port       swp3.200 (#1)
  path cost     20         internal path cost   0
  max age       20         bridge max age       20
  forward delay 15         bridge forward delay 15
  tx hold count 6          max hops             20
  hello time    2          ageing time          300
  force protocol version     rstp
  time since topology change 483s
  topology change count      17
  topology change            no
  topology change port       swp2.200
  last topology change port  swp1.200
root@SW-TOR4-CMS:/home/cumulus# mstpctl showport br-tor4-200
   swp1.200 8.002 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:09:00:01 8.002 Desg
   swp2.200 8.003 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:09:00:01 8.003 Desg
   swp3.200 8.001 forw 8.000.50:00:00:02:00:02 8.0C8.AA:BB:CC:00:05:00 8.006 Root
 E swp5  8.004 forw 8.000.50:00:00:02:00:02 8.000.50:00:00:09:00:01 8.004 Desg
root@SW-TOR4-CMS:/home/cumulus#

Figure 6 describe the traffic flow in switch network based on verification that using PVSTP method.
Figure 6 - Use Case 3 Traffic Flow

3. Reference


  1. Cisco System. 2006. Understanding and Configuring Spanning Tree Protocol (STP) on Catalyst Switches. Cisco (Online : http://www.cisco.com/c/en/us/support/docs/lan-switching/spanning-tree-protocol/5234-5.html )
  2. IEEE Computer Society. 1998. IEEE Standard for Information technology - Telecommunications and information exchange between systems - Local and metropolitan area networks - Common specifications Part 3: Media Access Control (MAC) Bridges. New Jersey
  3. IEEE Computer Society. 2004. IEEE Standard for Local and metropolitan area networks - Media Access Control (MAC) Bridges. New York: IEEE
  4. Kent Hundley.2009.Alcatel-Lucent Scalable IP Networks Self-Study Guide: Preparing for the Network Routing Specialist I (NRS 1) Certification Exam (4A0-100). Indianapolis: Wiley
  5. Pete Bratach. 2016. Spanning Tree and Rapid Spanning Tree. Cumulus Networks (Online: https://docs.cumulusnetworks.com/display/DOCS/Spanning+Tree+and+Rapid+Spanning+Tree)
  6. Sean Cavanaugh. 2016. Cumulus Linux vs Cisco IOS: Spanning Tree Protocol. Cumulus Network (Online : https://support.cumulusnetworks.com/hc/en-us/articles/206908397-Cumulus-Linux-vs-Cisco-IOS-Spanning-Tree-Protocol)

No comments:

Post a Comment