Header Navigation

Tuesday, May 31, 2016

Nokia-Juniper-Cisco Part- 2 - IS-IS Routing Protocol Configuration

1. Overview

The IS-IS Routing Protocol has been developed in ISO to provide routing for pure OSI environments. In particular, IS-IS is designed to work in conjunction with ISO 8473 (The ISO Connectionless Network Layer Protocol), and ISO 9542 (The ISO End System to Intermediate System Protocol).  – RFC 1195



1.1 System Type Component

There are the following types of system:
End Systems: These systems deliver NPDUs to other systems and receive Network Protocol Data Unit (NPDU)s from other systems, but do not relay NPDUs. This International Standard does not specify any additional End system functions beyond those supplied by ISO 8473 and ISO 9542.
Level 1 Intermediate Systems: These systems deliver and receive NPDUs from other systems, and relay NPDUs from other source systems to other destination systems. They route directly to systems within their own area, and route towards a level 2 Intermediate system when the destination system is in a different area. 
Level 2 Intermediate Systems: These systems act as Level 1 Intermediate systems in addition to acting as a system in the subdomain consisting of level 2 ISs. Systems in the level 2 subdomain route towards a destination area, or another routing domain.

1.2 Topology, Packet Data Unit Flooding System, Neighbor Adjacency, Path Computation

A single organization may wish to divide its Administrative Domain into a number of separate Routing Domains. 
Routing domain is divided into "areas" same with OSPF. But there is no Backbone and Non-Backbone area router in ISIS, We call it Level 1 and Level 2. 
Level 1 routers know the topology in their area including End system (in OSPF we call it Host). Level-1 routers do not know the router destination outside their area. They forward all traffic to Level-2 routers to reach that destination. Only Level-2 router can exchange routing information with external routers or we call it external realm. And Level-2 routers never know the topology in level-1 area.
For special case we will meet level 1/level 2 router type, it has capability to exchange information between level 1 and level 2 area. Below based on RFC 1142 the characteristic of Packet Data Unit that process in IS-IS:
  • Link State PDUs are generated as a result of topological changes, and also periodically. They may also be generated indirectly as a result of System Management actions (such as changing one of the routing metrics for a circuit).
  • Level 1 Link State PDUs are propagated to all Intermediate systems within an area, but are not propagated out of an area.
  • Level 2 Link State PDUs are propagated to all Level 2 Intermediate systems in the domain.
  • Link State PDUs are not propagated outside of a domain.
  • The update process, through a set of System Management parameters, enforces an upper bound on the amount of routing traffic overhead it generates.
IS-IS support 2 network type they are point-to-point network and broadcast network. When implement broadcast network the Designator Intermediate system is preferred. Unlike OSPF DIS DIS election is pre-emptive, and no backup DIS in IS-IS.
When flooding the PDU information IS-IS using unique L2 broadcast address for broadcast network and unique point-to-point address for point-to-point network:
  • On a broadcast interface, L1 updates use 0180:C200:0014. 
  • On a broadcast interface, L2 updates use 0180:C200:0015.
  • On a point-to-point interface 0900:2b00:0005 is used (all IS-IS routers)
Neighbor adjacency using PDU that received from IS-IS unique mac address and have terminology like below:
  • Hello packets are used to discover and maintain neighbor adjacencies. It’s sends every 9 sec, with holding time 27 sec
  • There are separate adjacencies for Level 1 and Level 2 LSP from one router
When neighbor was establish and all routing information completed received, the next process is decide the route destination based on SPF best path computation. In IS-IS the default metric is not depend bandwidth but automatically set metric to 10

1.3 NSAP addressing

1.3.1 Overview

NSAP addresses provide a flexible, variable length addressing format, which allows for multi-level hierarchical address assignment. These addresses provide the flexibility needed to solve two critical problems simultaneously: (i) How to administer a worldwide address space; and (ii) How to assign addresses in a manner which makes routing scale well in a worldwide Internet. – RFC 1629

  • IDP : Initial Domain Part, the part which is standardized by ISO, and specifies the format and authority responsible for assigning the rest of the address.
    • AFI : Authority and Format Identifier, this part is using for authority for unique global IDP. The AFI indicates the type of authority through which the address was assigned and the format of the address. The common of this address is:
      • 49 : Private (not registered with any international or national authority)
      • 47 : Assigned as International authority, issued by ISO
      • 39 : Single Country authority, issued by standards body for country like ANSI
    • IDI : Initial Domain Identifier, it’s refer to identify the authority that assigned the domain identifier. Each country's organization has an AFI and IDI. 
      • 49 : 0 (none)
      • 47 : based on ISO authority
      • 39 : based on national standard authority
      • Example: all domains issued by ANSI have an AFI of 39 and an IDI of 840, which makes an initial domain part of 39.840
        Note:  For this case, we need use the private address so we refer to 49.000
  • DSP : Domain Specific Part. It provides unique addresses within a specific IDP value. Different routing architectures might format and use the DSP in different ways. Refer to OSI IS-IS (ISO 10589) for more detail
    • HO-DSP : High Order-Domain Specific Part, this part refer to sub domain. This part can allow assign sub address authority for domain routing. For Inter domain routing, it’s related to area.
      Example : in IS-IS domain they are area 1, 2, and 3. Where the AFI is 49 and IDI is 0, so the NSAP address is 49.0001.XXXX.00, 49.0002.XXXX.00, 49.0003.XXXX.00 where the XXXX is IS-IS system id for intermediate system (i.e. router).
    • System Identifier (ID): The system ID identifies a particular end system, generally in the form of 48-bit Media Access Control (MAC) addresses, and it’s configurable in router
    • NSAP Selector (NSEL): The NSEL indicates which service on the end system is interested in this packet. The NSEL allows several types of traffic to be multiplexed over one pair of addresses. Thes SEL values:
      • 20 (for NSAP specifying NSP transport)
      • 21 (for NSAP specifying OSI transport)
      • 00 (for an NET), we use this for IP network

1.3.2 NSAP Addressing related IS-IS routing protocol

Adopted from NSAP addressing, this part explain how to defined NSAP address related to IS-IS intra domain protocol. Below the structure address:
AFI and IDP related to Single autonomous authority, for this part when using private AFI address you may fill blank 0 for IDP or defined based on administrator configuration. 
Note: The N selector is generally ignored when working with routing protocols because it denotes a service on an end system, and routing protocols are concerned with routing to end systems, not the services on them.
Example: 
System C address: 49.0001.2222.0000.0000.000C.00
49.0001.2222 is the area ID
0000.0000.000C is the system ID

1.3.3 NSAP Address conversion from IP loopback/System

Special case, you have to create NSAP address, like cisco and juniper, NSAP address is mandatory. Here below, useful conversion technique:
  • IP Loopback/System : 192.168.10.1/32
  • Add "0" to  each subnet so it contains has 3 digit number, if the subnet has been contain 3 digit, you don't need to.
    Example: 192.168.100.001
  • Remove the dot
    Example: 192168100001
  • Divide in 4 digit, then separated with dot
    Example: 1921.6810.0001
  • Add IDP address, it's refer to IS-IS area. for this example We use private AFI and the router in Area 1
    Example: 49.0001.1921.6810.0001
  • Last, add selector ID .00
    Example: 49.0001.1921.6810.0001.00

1.4 IS-IS Router level capability, Interface capability and Potential Adjacency

As mention above there is 2 level capability that router have level 1, level 2 and level 1/2.  Each router capability may send out different PDU. And receive or block PDU refer to their level router capability configuration. It’s described in table below:

Based on Interface capability to receive PDU, the information explain in table below:

From information above, we can summarize, the router / global level capability configuration when meet interface level capability configuration, can make potential adjacency like below:

2. Configuration

2.1 Topology and Interface Information

Below the topology that tested in LAB. There are 6 routers. 3 routers as L1 and L2 router and 3 router as L1 router. 

Below the loopback/system IP information:


There are 3 area, area 49.0001 until 49.0003, Area mapping for all routers described in picture below:



Some option, that used in LAB test are:

  • Basic Configuration is done. If you still confuse about interface configuration and other basic configuration, please refer to this link: http://www.achyarnurandi.net/2016/04/nokia-juniper-cisco-part-1-ospf-routing.html 
  • Using interface type point to point
  • L1 router just enable circuit type level-1
  • L1/L2 router enable circuit type level-1 for intra-area and circuit type level-2 for backbone to communicate intra-area
  • There is no leaking. So in L1 router just default route installed

2.2 Configuration

2.2.1 Area 49.001

In this area for L1/L2 Router is Cisco CRS (LAB-P3-CRS) and Juniper vMX as L1 Router (LAB-PE5-MX)

LAB-P3-CRS Configuration
RP/0/0/CPU0:LAB-P3-CRS(config)#router isis 1
RP/0/0/CPU0:LAB-P3-CRS(config-isis)#net 49.0001.1921.6802.0003.00
RP/0/0/CPU0:LAB-P3-CRS(config-isis)#address-family ipv4 unicast
RP/0/0/CPU0:LAB-P3-CRS(config-isis-af)#exit
RP/0/0/CPU0:LAB-P3-CRS(config-isis)#interface Loopback 0
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if)#address-family ipv4 unicast
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if-af)#exit
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if)#exit
RP/0/0/CPU0:LAB-P3-CRS(config-isis)#interface GigabitEthernet 0/0/0/0
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if)#point-to-point
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if)#circuit-type level-2-only
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if)#address-family ipv4 unicast
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if-af)#exit
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if)#exit
RP/0/0/CPU0:LAB-P3-CRS(config-isis)#interface GigabitEthernet 0/0/0/2
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if)#point-to-point
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if)#circuit-type level-2-only
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if)#address-family ipv4 unicast
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if-af)#exit
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if)#exit
RP/0/0/CPU0:LAB-P3-CRS(config-isis)#interface GigabitEthernet 0/0/0/1
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if)#point-to-point
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if)#circuit-type level-1
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if)#circuit-type level-1
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if)#address-family ipv4 unicast
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if-af)#exit
RP/0/0/CPU0:LAB-P3-CRS(config-isis-if)#exit
RP/0/0/CPU0:LAB-P3-CRS(config-isis)#commit

RP/0/0/CPU0:LAB-P3-CRS(config)#show running-config router isis
Fri May 27 03:59:57.432 UTC
router isis 1
 net 49.0001.1921.6802.0003.00
 address-family ipv4 unicast
 !
 interface Loopback0
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/0
  circuit-type level-2-only
  point-to-point
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/1
  circuit-type level-1
  point-to-point
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/2
  circuit-type level-2-only
  point-to-point
  address-family ipv4 unicast
  !
 !
!

RP/0/0/CPU0:LAB-P3-CRS(config)#

LAB-PE5-MX Configuration
root@LAB-P2-MX# set interfaces ge-0/0/0 unit 0 family inet address 192.168.10.21/30
root@LAB-P2-MX# set interfaces ge-0/0/0 unit 0 family iso
root@LAB-P2-MX# set interfaces lo0 unit 0 family inet address 192.168.20.5/32
root@LAB-P2-MX# set interfaces lo0 unit 0 family iso address 49.0001.1921.6802.0005.00
root@LAB-P2-MX# set protocols isis interface ge-0/0/0.0 point-to-point
root@LAB-P2-MX# set protocols isis interface ge-0/0/0.0 level 2 disable
root@LAB-P2-MX# set protocols isis interface lo0.0


[edit]
root@LAB-PE5-MX# show interfaces ge-0/0/0
description to_LAB-P3-CRS;
unit 0 {
    family inet {
        address 192.168.10.21/30;
    }
    family iso;
}

[edit]
root@LAB-PE5-MX# show interfaces lo0
unit 0 {
    family inet {
        address 192.168.20.5/32;
    }
    family iso {
        address 49.0001.1921.6802.0005.00;
    }
}

[edit]
root@LAB-PE5-MX# show protocols isis
interface ge-0/0/0.0 {
    point-to-point;
    level 2 disable;
}
interface lo0.0;

[edit]
root@LAB-PE5-MX#

2.2.2 Area 49.002

In this area for L1/L2 Router is Nokia 7750 SR (LAB-P1-SR) and Cisco CRS as L1 Router (LAB-PE6-CRS)

LAB-P1-SR Configuration
A:LAB-P1-SR# configure router
A:LAB-P1-SR>config>router# interface "system"
A:LAB-P1-SR>config>router>if# address 192.168.20.1/32
A:LAB-P1-SR>config>router>if# no shutdown
A:LAB-P1-SR>config>router>if# exit
A:LAB-P1-SR>config>router# interface "to_LAB-P2-MX"
A:LAB-P1-SR>config>router>if# address 192.168.10.10/30
A:LAB-P1-SR>config>router>if# port 1/1/1
A:LAB-P1-SR>config>router>if# no shutdown
A:LAB-P1-SR>config>router>if# exit
A:LAB-P1-SR>config>router# interface "to_LAB-P3-CRS"
A:LAB-P1-SR>config>router>if# address 192.168.10.6/30
A:LAB-P1-SR>config>router>if# port 1/1/3
A:LAB-P1-SR>config>router>if# no shutdown
A:LAB-P1-SR>config>router>if# exit
A:LAB-P1-SR>config>router# interface "to_LAB-PE6-CRS"
A:LAB-P1-SR>config>router>if# address 192.168.10.13/30
A:LAB-P1-SR>config>router>if# port 1/1/2
A:LAB-P1-SR>config>router>if# no shutdown
A:LAB-P1-SR>config>router>if# exit
A:LAB-P1-SR>config>router# router-id 192.168.20.1
A:LAB-P1-SR>config>router#

A:LAB-P1-SR>config>router# isis
A:LAB-P1-SR>config>router>isis# area-id 49.0002
A:LAB-P1-SR>config>router>isis# interface "system"
A:LAB-P1-SR>config>router>isis>if# no shutdown
A:LAB-P1-SR>config>router>isis>if# exit
A:LAB-P1-SR>config>router>isis# interface "to_LAB-P2-MX"
A:LAB-P1-SR>config>router>isis>if# level-capability level-2
A:LAB-P1-SR>config>router>isis>if# interface-type point-to-point
A:LAB-P1-SR>config>router>isis>if# no shutdown
A:LAB-P1-SR>config>router>isis>if# exit
A:LAB-P1-SR>config>router>isis# interface "to_LAB-P3-CRS"
A:LAB-P1-SR>config>router>isis>if# level-capability level-2
A:LAB-P1-SR>config>router>isis>if# interface-type point-to-point
A:LAB-P1-SR>config>router>isis>if# no shutdown
A:LAB-P1-SR>config>router>isis>if# exit
A:LAB-P1-SR>config>router>isis# interface "to_LAB-PE6-CRS"
A:LAB-P1-SR>config>router>isis>if# level-capability level-1
A:LAB-P1-SR>config>router>isis>if# interface-type point-to-point
A:LAB-P1-SR>config>router>isis>if# no shutdown
A:LAB-P1-SR>config>router>isis>if# exit
A:LAB-P1-SR>config>router>isis# no shutdown
A:LAB-P1-SR>config>router>isis# exit
A:LAB-P1-SR>config>router#





A:LAB-P1-SR# configure router
A:LAB-P1-SR>config>router# info
----------------------------------------------
#--------------------------------------------------
echo "IP Configuration"
#--------------------------------------------------
        interface "system"
            address 192.168.20.1/32
            no shutdown
        exit
        interface "to_LAB-P2-MX"
            address 192.168.10.10/30
            port 1/1/1
            no shutdown
        exit
        interface "to_LAB-P3-CRS"
            address 192.168.10.6/30
            port 1/1/3
            no shutdown
        exit
        interface "to_LAB-PE6-CRS"
            address 192.168.10.13/30
            port 1/1/2
            no shutdown
        exit
        router-id 192.168.20.1
#--------------------------------------------------
echo "ISIS Configuration"
#--------------------------------------------------
        isis
            area-id 49.0002
            interface "system"
                no shutdown
            exit
            interface "to_LAB-P2-MX"
                level-capability level-2
                interface-type point-to-point
                no shutdown
            exit
            interface "to_LAB-P3-CRS"
                level-capability level-2
                interface-type point-to-point
                no shutdown
            exit
            interface "to_LAB-PE6-CRS"
                level-capability level-1
                interface-type point-to-point
                no shutdown
            exit
            no shutdown
        exit
----------------------------------------------
A:LAB-P1-SR>config>router#

LAB-PE6-CRS Configuration
RP/0/0/CPU0:LAB-PE6-CRS(config)#router isis 1
RP/0/0/CPU0:LAB-PE6-CRS(config-isis)#net 49.0002.1921.6802.0006.00
RP/0/0/CPU0:LAB-PE6-CRS(config-isis)#address-family ipv4 unicast
RP/0/0/CPU0:LAB-PE6-CRS(config-isis-af)#exit
RP/0/0/CPU0:LAB-PE6-CRS(config-isis)#interface loopback 0
RP/0/0/CPU0:LAB-PE6-CRS(config-isis-if)#address-family ipv4 unicast
RP/0/0/CPU0:LAB-PE6-CRS(config-isis-if-af)#ex
RP/0/0/CPU0:LAB-PE6-CRS(config-isis-if)#ex
RP/0/0/CPU0:LAB-PE6-CRS(config-isis)#interface gigabitEthernet 0/0/0/0
RP/0/0/CPU0:LAB-PE6-CRS(config-isis-if)#point-to-point
RP/0/0/CPU0:LAB-PE6-CRS(config-isis-if)#circuit-type level-1
RP/0/0/CPU0:LAB-PE6-CRS(config-isis-if)#address-family ipv4 unicast
RP/0/0/CPU0:LAB-PE6-CRS(config-isis-if-af)#ex
RP/0/0/CPU0:LAB-PE6-CRS(config-isis-if)#ex
RP/0/0/CPU0:LAB-PE6-CRS(config-isis)#commit
Fri May 27 06:17:54.655 UTC

RP/0/0/CPU0:LAB-PE6-CRS#show running-config router isis
Fri May 27 07:10:55.847 UTC
router isis 1
 net 49.0002.1921.6802.0006.00
 address-family ipv4 unicast
 !
 interface Loopback0
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/0
  circuit-type level-1
  point-to-point
  address-family ipv4 unicast
  !
 !
!

RP/0/0/CPU0:LAB-PE6-CRS#

2.2.3 Area 49.003

In this area for L1/L2 Router is Juniper vMX (LAB-P2-MX) and Nokia 7750 SR as L1 Router (LAB-PE4-SR)

LAB-P2-MX Configuration
root@LAB-P2-MX# set interfaces lo0 unit 0 family inet address 192.168.20.2/32
root@LAB-P2-MX# set interfaces lo0 unit 0 family iso address 49.0001.1921.6802.0002.00
root@LAB-P2-MX# set interfaces ge-0/0/0 description to_LAB-P1-SR
root@LAB-P2-MX# set interfaces ge-0/0/0 unit 0 family inet address 192.168.10.9/30
root@LAB-P2-MX# set interfaces ge-0/0/0 unit 0 family iso
root@LAB-P2-MX# set interfaces ge-0/0/1 description to_LAB-PE4-SR
root@LAB-P2-MX# set interfaces ge-0/0/1 unit 0 family inet address 192.168.10.17/30
root@LAB-P2-MX# set interfaces ge-0/0/1 unit 0 family iso
root@LAB-P2-MX# set interfaces ge-0/0/2 description to_LAB-P3-CRS
root@LAB-P2-MX# set interfaces ge-0/0/2 unit 0 family inet address 192.168.10.2/30
root@LAB-P2-MX# set interfaces ge-0/0/2 unit 0 family iso
root@LAB-P2-MX# set interfaces lo0 unit 0 family inet address 192.168.20.2/32
root@LAB-P2-MX# set interfaces lo0 unit 0 family iso address 49.0002.1921.6802.0002.00
root@LAB-P2-MX# set routing-options router-id 192.168.20.2
root@LAB-P2-MX# set protocols isis interface ge-0/0/0.0 point-to-point
root@LAB-P2-MX# set protocols isis interface ge-0/0/0.0 level 1 disable
root@LAB-P2-MX# set protocols isis interface ge-0/0/1.0 point-to-point
root@LAB-P2-MX# set protocols isis interface ge-0/0/1.0 level 2 disable
root@LAB-P2-MX# set protocols isis interface ge-0/0/2.0 point-to-point
root@LAB-P2-MX# set protocols isis interface ge-0/0/2.0 level 1 disable
root@LAB-P2-MX# set protocols isis interface lo0.0


[edit]
root@LAB-P2-MX#


[edit]
root@LAB-P2-MX# show interfaces ge-0/0/0
description to_LAB-P1-SR;
unit 0 {
    family inet {
        address 192.168.10.9/30;
    }
    family iso;
}

[edit]
root@LAB-P2-MX# show interfaces ge-0/0/1
description to_LAB-PE4-SR;
unit 0 {
    family inet {
        address 192.168.10.17/30;
    }
    family iso;
}

[edit]
root@LAB-P2-MX# show interfaces ge-0/0/2
description to_LAB-P3-CRS;
unit 0 {
    family inet {
        address 192.168.10.2/30;
    }
    family iso;
}

[edit]
root@LAB-P2-MX# show interfaces lo0
unit 0 {
    family inet {
        address 192.168.20.2/32;
    }
    family iso {
        address 49.0001.1921.6802.0002.00;
    }
}


[edit]
root@LAB-P2-MX# show routing-options
router-id 192.168.20.2;

[edit]
root@LAB-P2-MX#



[edit]
root@LAB-P2-MX#


[edit]
root@LAB-P2-MX# show protocols isis
interface ge-0/0/0.0 {
    point-to-point;
    level 1 disable;
}
interface ge-0/0/1.0 {
    point-to-point;
    level 2 disable;
}
interface ge-0/0/2.0 {
    point-to-point;
    level 1 disable;
}
interface lo0.0;

LAB-PE4-SR Configuration
A:LAB-PE4-SR# configure router
A:LAB-PE4-SR>config>router# interface "system"
A:LAB-PE4-SR>config>router>if# address 192.168.20.4/32
A:LAB-PE4-SR>config>router>if# no shutdown
A:LAB-PE4-SR>config>router>if# exit
A:LAB-PE4-SR>config>router# interface "to_LAB-P2-MX"
A:LAB-PE4-SR>config>router>if# address 192.168.10.18/30
A:LAB-PE4-SR>config>router>if# port 1/1/1
A:LAB-PE4-SR>config>router>if# no shutdown
A:LAB-PE4-SR>config>router>if# exit
A:LAB-PE4-SR>config>router# router-id 192.168.20.4
A:LAB-PE4-SR>config>router# isis
A:LAB-PE4-SR>config>router>isis# area-id 49.0003
A:LAB-PE4-SR>config>router>isis# interface "system"
A:LAB-PE4-SR>config>router>isis>if# no shutdown
A:LAB-PE4-SR>config>router>isis>if# exit
A:LAB-PE4-SR>config>router>isis# interface "to_LAB-P2-MX"
A:LAB-PE4-SR>config>router>isis>if# level-capability level-1
A:LAB-PE4-SR>config>router>isis>if# interface-type point-to-point
A:LAB-PE4-SR>config>router>isis>if# no shutdown
A:LAB-PE4-SR>config>router>isis>if# exit
A:LAB-PE4-SR>config>router>isis# no shutdown
A:LAB-PE4-SR>config>router>isis# exit
A:LAB-PE4-SR>config>router#


A:LAB-PE4-SR>config>router# info
----------------------------------------------
#--------------------------------------------------
echo "IP Configuration"
#--------------------------------------------------
        interface "system"
            address 192.168.20.4/32
            no shutdown
        exit
        interface "to_LAB-P2-MX"
            address 192.168.10.18/30
            port 1/1/1
            no shutdown
        exit
        router-id 192.168.20.4
#--------------------------------------------------
echo "ISIS Configuration"
#--------------------------------------------------
        isis
            area-id 49.0003
            interface "system"
                no shutdown
            exit
            interface "to_LAB-P2-MX"
                level-capability level-1
                interface-type point-to-point
                no shutdown
            exit
            no shutdown
        exit
----------------------------------------------
A:LAB-PE4-SR>config>router#

2.3 Validation

2.3.1 Area 49.001

LAB-P3-CRS ISIS interface information, adjacency information, route table information
RP/0/0/CPU0:LAB-P3-CRS#show isis interface brief
Sun May 29 09:17:44.960 UTC

IS-IS 1 Interfaces
    Interface      All     Adjs    Adj Topos  Adv Topos  CLNS   MTU    Prio
                   OK    L1   L2    Run/Cfg    Run/Cfg                L1   L2
-----------------  ---  ---------  ---------  ---------  ----  ----  --------
Lo0                Yes    0    0      1/1        1/1     Up    1500    -    -
Gi0/0/0/0          Yes    -    1      1/1        1/1     Up    1497    -    -
Gi0/0/0/1          Yes    1    -      1/1        1/1     Up    1497    -    -
Gi0/0/0/2          Yes    -    1      1/1        1/1     Up    1497    -    -
RP/0/0/CPU0:LAB-P3-CRS#show isis adjacency
Sun May 29 09:17:52.589 UTC

IS-IS 1 Level-1 adjacencies:
System Id      Interface        SNPA           State Hold Changed  NSF IPv4 IPv6
                                                                       BFD  BFD
LAB-PE5-MX     Gi0/0/0/1        *PtoP*         Up    21   00:07:20 Yes None None

Total adjacency count: 1

IS-IS 1 Level-2 adjacencies:
System Id      Interface        SNPA           State Hold Changed  NSF IPv4 IPv6
                                                                       BFD  BFD
LAB-P2-MX      Gi0/0/0/0        *PtoP*         Up    26   00:07:20 Yes None None
LAB-P1-SR      Gi0/0/0/2        *PtoP*         Up    22   00:07:20 No  None None

RP/0/0/CPU0:LAB-P3-CRS#show isis database
Sun May 29 09:18:49.505 UTC

IS-IS 1 (Level-1) Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
LAB-P3-CRS.00-00    * 0x00000005   0xeb8f        711             1/0/0
LAB-PE5-MX.00-00      0x00000003   0x8012        704             0/0/0

 Total Level-1 LSP count: 2     Local Level-1 LSP count: 1

IS-IS 1 (Level-2) Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
LAB-P1-SR.00-00       0x00000006   0x066f        706             0/0/0
LAB-P2-MX.00-00       0x00000005   0xc091        704             0/0/0
LAB-P3-CRS.00-00    * 0x00000007   0x6aaf        711             0/0/0

 Total Level-2 LSP count: 3     Local Level-2 LSP count: 1
RP/0/0/CPU0:LAB-P3-CRS#

Total adjacency count: 2
RP/0/0/CPU0:LAB-P3-CRS#show route isis
Sun May 29 09:18:16.718 UTC

i L2 192.168.10.8/30 [115/20] via 192.168.10.6, 00:07:40, GigabitEthernet0/0/0/2
                     [115/20] via 192.168.10.2, 00:07:40, GigabitEthernet0/0/0/0
i L2 192.168.10.12/30 [115/20] via 192.168.10.6, 00:07:40, GigabitEthernet0/0/0/2
i L2 192.168.10.16/30 [115/20] via 192.168.10.2, 00:07:40, GigabitEthernet0/0/0/0
i L2 192.168.20.1/32 [115/10] via 192.168.10.6, 00:07:40, GigabitEthernet0/0/0/2
i L2 192.168.20.2/32 [115/10] via 192.168.10.2, 00:07:40, GigabitEthernet0/0/0/0
i L2 192.168.20.4/32 [115/20] via 192.168.10.2, 00:07:40, GigabitEthernet0/0/0/0
i L1 192.168.20.5/32 [115/10] via 192.168.10.21, 00:07:40, GigabitEthernet0/0/0/1
i L2 192.168.20.6/32 [115/30] via 192.168.10.6, 00:07:40, GigabitEthernet0/0/0/2


System/loopback to P3-MX and PE-4-SR result
RP/0/0/CPU0:LAB-P3-CRS#ping 192.168.20.3
Sun May 29 09:29:36.271 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:LAB-P3-CRS#

RP/0/0/CPU0:LAB-P3-CRS#ping 192.168.20.4
Sun May 29 09:28:04.447 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 9/15/39 ms
RP/0/0/CPU0:LAB-P3-CRS#

LAB-PE5-MX ISIS interface information, adjacency information, route table information
root@LAB-PE5-MX> show isis interface
IS-IS interface database:
Interface             L CirID Level 1 DR        Level 2 DR        L1/L2 Metric
ge-0/0/0.0            1   0x1 Point to Point    Disabled               10/10
lo0.0                 3   0x1 Passive           Passive                 0/0

root@LAB-PE5-MX>

[edit]
root@LAB-PE5-MX# run show isis adjacency
Interface             System         L State        Hold (secs) SNPA
ge-0/0/0.0            LAB-P3-CRS     1  Up                   27

[edit]
root@LAB-PE5-MX# run show isis database
IS-IS level 1 link-state database:
LSP ID                      Sequence Checksum Lifetime Attributes
LAB-P3-CRS.00-00                0x15   0xcb9f      351 L1 L2 Attached
LAB-PE5-MX.00-00                 0x8   0xf695      686 L1 L2
  2 LSPs

IS-IS level 2 link-state database:
LSP ID                      Sequence Checksum Lifetime Attributes
LAB-PE5-MX.00-00                 0x8   0xa7c9      906 L1 L2
  1 LSPs

root@LAB-PE5-MX# run show route protocol isis

inet.0: 5 destinations, 5 routes (5 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

0.0.0.0/0          *[IS-IS/15] 01:24:57, metric 10
                    > to 192.168.10.22 via ge-0/0/0.0
192.168.20.3/32    *[IS-IS/15] 01:24:57, metric 20
                    > to 192.168.10.22 via ge-0/0/0.0

iso.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)

System/loopback to P1-SR and PE-6-CRS result
root@LAB-PE5-MX> ping 192.168.20.1 count 5
PING 192.168.20.1 (192.168.20.1): 56 data bytes
64 bytes from 192.168.20.1: icmp_seq=0 ttl=63 time=61.104 ms
64 bytes from 192.168.20.1: icmp_seq=1 ttl=63 time=10.213 ms
64 bytes from 192.168.20.1: icmp_seq=2 ttl=63 time=9.141 ms
64 bytes from 192.168.20.1: icmp_seq=3 ttl=63 time=10.921 ms
64 bytes from 192.168.20.1: icmp_seq=4 ttl=63 time=11.388 ms

--- 192.168.20.1 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/stddev = 9.141/20.553/61.104/20.289 ms

root@LAB-PE5-MX> ping 192.168.20.6 count 5
PING 192.168.20.6 (192.168.20.6): 56 data bytes
64 bytes from 192.168.20.6: icmp_seq=0 ttl=253 time=20.858 ms
64 bytes from 192.168.20.6: icmp_seq=1 ttl=253 time=18.459 ms
64 bytes from 192.168.20.6: icmp_seq=2 ttl=253 time=47.124 ms
64 bytes from 192.168.20.6: icmp_seq=3 ttl=253 time=53.410 ms
64 bytes from 192.168.20.6: icmp_seq=4 ttl=253 time=63.705 ms

--- 192.168.20.6 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/stddev = 18.459/40.711/63.705/18.002 ms

root@LAB-PE5-MX>

2.3.2 Area 49.002

LAB-P1-SR ISIS interface information, adjacency information, route table information
A:LAB-P1-SR# show router isis interface

===============================================================================
Router Base ISIS Instance 0 Interfaces
===============================================================================
Interface                        Level CircID  Oper State   L1/L2 Metric
-------------------------------------------------------------------------------
system                           L1L2  1       Up           0/0
to_LAB-P2-MX                     L2    2       Up           -/10
to_LAB-P3-CRS                    L2    3       Up           -/10
to_LAB-PE6-CRS                   L1    4       Up           10/-
-------------------------------------------------------------------------------
Interfaces : 4
===============================================================================
A:LAB-P1-SR# /show router isis adjacency

===============================================================================
Router Base ISIS Instance 0 Adjacency
===============================================================================
System ID                Usage State Hold Interface                     MT-ID
-------------------------------------------------------------------------------
LAB-P2-MX                L2    Up    24   to_LAB-P2-MX                  0
LAB-P3-CRS               L2    Up    29   to_LAB-P3-CRS                 0
LAB-PE6-CRS              L1    Up    25   to_LAB-PE6-CRS                0
-------------------------------------------------------------------------------
Adjacencies : 3
===============================================================================
A:LAB-P1-SR#

A:LAB-P1-SR# show router isis routes

===============================================================================
Router Base ISIS Instance 0 Route Table
===============================================================================
Prefix[Flags]                     Metric     Lvl/Typ     Ver.  SysID/Hostname
  NextHop                                                MT     AdminTag
-------------------------------------------------------------------------------
192.168.10.0/30                   20         2/Int.      4     LAB-P2-MX
   192.168.10.9                                            0       0
192.168.10.4/30                   10         1/Int.      4     LAB-P1-SR
   0.0.0.0                                                 0       0
192.168.10.8/30                   10         1/Int.      4     LAB-P1-SR
   0.0.0.0                                                 0       0
192.168.10.12/30                  10         1/Int.      4     LAB-P1-SR
   0.0.0.0                                                 0       0
192.168.10.16/30                  20         2/Int.      4     LAB-P2-MX
   192.168.10.9                                            0       0
192.168.10.20/30                  20         2/Int.      4     LAB-P3-CRS
   192.168.10.5                                            0       0
192.168.20.1/32                   0          1/Int.      2     LAB-P1-SR
   0.0.0.0                                                 0       0
192.168.20.2/32                   10         2/Int.      4     LAB-P2-MX
   192.168.10.9                                            0       0
192.168.20.3/32                   20         2/Int.      4     LAB-P3-CRS
   192.168.10.5                                            0       0
192.168.20.4/32                   20         2/Int.      4     LAB-P2-MX
   192.168.10.9                                            0       0
192.168.20.5/32                   20         2/Int.      4     LAB-P3-CRS
   192.168.10.5                                            0       0
192.168.20.6/32                   20         1/Int.      4     LAB-PE6-CRS
   192.168.10.14                                           0       0
-------------------------------------------------------------------------------
No. of Routes: 12
Flags: L = LFA nexthop available
===============================================================================
A:LAB-P1-SR#

System/loopback to P3-CRS and PE-5-MX result
A:LAB-P1-SR# ping 192.168.20.3
PING 192.168.20.3 56 data bytes
64 bytes from 192.168.20.3: icmp_seq=1 ttl=255 time=5.48ms.
64 bytes from 192.168.20.3: icmp_seq=2 ttl=255 time=5.75ms.
64 bytes from 192.168.20.3: icmp_seq=3 ttl=255 time=46.6ms.
64 bytes from 192.168.20.3: icmp_seq=4 ttl=255 time=48.8ms.
64 bytes from 192.168.20.3: icmp_seq=5 ttl=255 time=48.8ms.

---- 192.168.20.3 PING Statistics ----
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min = 5.48ms, avg = 31.1ms, max = 48.8ms, stddev = 20.8ms
A:LAB-P1-SR# ping 192.168.20.5
PING 192.168.20.5 56 data bytes
64 bytes from 192.168.20.5: icmp_seq=1 ttl=63 time=9.96ms.
64 bytes from 192.168.20.5: icmp_seq=2 ttl=63 time=10.4ms.
64 bytes from 192.168.20.5: icmp_seq=3 ttl=63 time=10.7ms.
64 bytes from 192.168.20.5: icmp_seq=4 ttl=63 time=24.9ms.
64 bytes from 192.168.20.5: icmp_seq=5 ttl=63 time=9.11ms.

---- 192.168.20.5 PING Statistics ----
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min = 9.11ms, avg = 13.0ms, max = 24.9ms, stddev = 5.95ms
A:LAB-P1-SR#

LAB-PE6-CRS ISIS interface information, adjacency information, route table information
RP/0/0/CPU0:LAB-PE6-CRS#show isis interface brief
Sun May 29 09:20:27.509 UTC

IS-IS 1 Interfaces
    Interface      All     Adjs    Adj Topos  Adv Topos  CLNS   MTU    Prio
                   OK    L1   L2    Run/Cfg    Run/Cfg                L1   L2
-----------------  ---  ---------  ---------  ---------  ----  ----  --------
Lo0                Yes    0    0      1/1        1/1     Up    1500    -    -
Gi0/0/0/0          Yes    1    -      1/1        1/1     Up    1497    -    -
RP/0/0/CPU0:LAB-PE6-CRS#show isis adjacency
Sun May 29 09:20:31.058 UTC

IS-IS 1 Level-1 adjacencies:
System Id      Interface        SNPA           State Hold Changed  NSF IPv4 IPv6
                                                                       BFD  BFD
LAB-P1-SR      Gi0/0/0/0        *PtoP*         Up    26   00:09:57 No  None None

Total adjacency count: 1

IS-IS 1 Level-2 adjacencies:
System Id      Interface        SNPA           State Hold Changed  NSF IPv4 IPv6
                                                                       BFD  BFD
RP/0/0/CPU0:LAB-PE6-CRS#show isis database
Sun May 29 09:20:35.118 UTC

IS-IS 1 (Level-1) Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
LAB-P1-SR.00-00       0x00000005   0xff64        1140            1/0/0
LAB-PE6-CRS.00-00   * 0x00000005   0x0a32        607             0/0/0

 Total Level-1 LSP count: 2     Local Level-1 LSP count: 1

IS-IS 1 (Level-2) Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
LAB-PE6-CRS.00-00   * 0x00000004   0x3231        605             0/0/0

 Total Level-2 LSP count: 1     Local Level-2 LSP count: 1
RP/0/0/CPU0:LAB-PE6-CRS#show route isis
Sun May 29 09:21:28.104 UTC

i*L1 0.0.0.0/0 [115/10] via 192.168.10.13, 00:10:50, GigabitEthernet0/0/0/0
i L1 192.168.20.1/32 [115/10] via 192.168.10.13, 00:10:50, GigabitEthernet0/0/0/0
RP/0/0/CPU0:LAB-PE6-CRS#

System/loopback to P2-MX and PE-4-SR result
RP/0/0/CPU0:LAB-PE6-CRS#ping 192.168.20.2
Sun May 29 09:42:13.519 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 9/19/29 ms
RP/0/0/CPU0:LAB-PE6-CRS#ping 192.168.20.4
Sun May 29 09:42:17.409 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 9/11/19 ms
RP/0/0/CPU0:LAB-PE6-CRS#

2.3.3 Area 49.003

LAB-P2-MX ISIS interface information, adjacency information, route table information
root@LAB-P2-MX> show isis interface
IS-IS interface database:
Interface             L CirID Level 1 DR        Level 2 DR        L1/L2 Metric
ge-0/0/0.0            2   0x1 Disabled          Point to Point         10/10
ge-0/0/1.0            1   0x1 Point to Point    Disabled               10/10
ge-0/0/2.0            2   0x1 Disabled          Point to Point         10/10
lo0.0                 3   0x1                   Passive                 0/0

root@LAB-P2-MX>

[edit]
root@LAB-P2-MX# run show isis adjacency
Interface             System         L State        Hold (secs) SNPA
ge-0/0/0.0            LAB-P1-SR      2  Up                   25
ge-0/0/2.0            LAB-P3-CRS     2  Up                   29

[edit]
root@LAB-P2-MX# run show isis database
IS-IS level 1 link-state database:
LSP ID                      Sequence Checksum Lifetime Attributes
LAB-P2-MX.00-00                 0x36    0x575      710 L1 L2 Attached
  1 LSPs

IS-IS level 2 link-state database:
LSP ID                      Sequence Checksum Lifetime Attributes
LAB-P1-SR.00-00                 0x44   0xec7b      645 L1 L2
LAB-P2-MX.00-00                 0x36   0x6c82      645 L1 L2
LAB-P3-CRS.00-00                 0x4   0x37ff      653 L1 L2
  3 LSPs

root@LAB-P2-MX> show route protocol isis

inet.0: 15 destinations, 15 routes (15 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

192.168.10.4/30    *[IS-IS/18] 00:34:44, metric 20
                      to 192.168.10.10 via ge-0/0/0.0
                    > to 192.168.10.1 via ge-0/0/2.0
192.168.10.12/30   *[IS-IS/18] 00:35:35, metric 20
                    > to 192.168.10.10 via ge-0/0/0.0
192.168.10.20/30   *[IS-IS/18] 00:34:36, metric 20
                    > to 192.168.10.1 via ge-0/0/2.0
192.168.20.1/32    *[IS-IS/18] 00:35:35, metric 10
                    > to 192.168.10.10 via ge-0/0/0.0
192.168.20.3/32    *[IS-IS/18] 00:34:44, metric 20
                    > to 192.168.10.1 via ge-0/0/2.0
192.168.20.4/32    *[IS-IS/15] 00:35:38, metric 10
                    > to 192.168.10.18 via ge-0/0/1.0
192.168.20.5/32    *[IS-IS/18] 00:34:36, metric 20
                    > to 192.168.10.1 via ge-0/0/2.0
192.168.20.6/32    *[IS-IS/18] 00:34:44, metric 30
                    > to 192.168.10.10 via ge-0/0/0.0

iso.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)

root@LAB-P2-MX>

System/loopback to P1-SR and PE-6-CRS result
RP/0/0/CPU0:LAB-P3-CRS#ping 192.168.20.3
Sun May 29 09:29:36.271 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:LAB-P3-CRS#

RP/0/0/CPU0:LAB-P3-CRS#ping 192.168.20.4
Sun May 29 09:28:04.447 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.20.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 9/15/39 ms
RP/0/0/CPU0:LAB-P3-CRS#

LAB-PE4-SR ISIS interface information, adjacency information, route table information
A:LAB-PE4-SR# show router isis interface

===============================================================================
Router Base ISIS Instance 0 Interfaces
===============================================================================
Interface                        Level CircID  Oper State   L1/L2 Metric
-------------------------------------------------------------------------------
system                           L1L2  1       Up           0/0
to_LAB-P2-MX                     L1    2       Up           10/-
-------------------------------------------------------------------------------
Interfaces : 2
===============================================================================
A:LAB-PE4-SR# show router isis adjacency

===============================================================================
Router Base ISIS Instance 0 Adjacency
===============================================================================
System ID                Usage State Hold Interface                     MT-ID
-------------------------------------------------------------------------------
LAB-P2-MX                L1    Up    26   to_LAB-P2-MX                  0
-------------------------------------------------------------------------------
Adjacencies : 1
===============================================================================
A:LAB-PE4-SR# show router isis routes

===============================================================================
Router Base ISIS Instance 0 Route Table
===============================================================================
Prefix[Flags]                     Metric     Lvl/Typ     Ver.  SysID/Hostname
  NextHop                                                MT     AdminTag
-------------------------------------------------------------------------------
0.0.0.0/0                         10         1/Int.      6     LAB-P2-MX
   192.168.10.17                                           0       0
192.168.10.16/30                  10         1/Int.      4     LAB-PE4-SR
   0.0.0.0                                                 0       0
192.168.20.4/32                   0          1/Int.      2     LAB-PE4-SR
   0.0.0.0                                                 0       0
-------------------------------------------------------------------------------
No. of Routes: 3
Flags: L = LFA nexthop available
===============================================================================
A:LAB-PE4-SR#

System/loopback to P3-CRS and PE-5-MX result
A:LAB-PE4-SR# ping 192.168.20.3
PING 192.168.20.3 56 data bytes
64 bytes from 192.168.20.3: icmp_seq=1 ttl=254 time=52.3ms.
64 bytes from 192.168.20.3: icmp_seq=2 ttl=254 time=195ms.
64 bytes from 192.168.20.3: icmp_seq=3 ttl=254 time=53.4ms.
64 bytes from 192.168.20.3: icmp_seq=4 ttl=254 time=451ms.
64 bytes from 192.168.20.3: icmp_seq=5 ttl=254 time=9.31ms.

---- 192.168.20.3 PING Statistics ----
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min = 9.31ms, avg = 152ms, max = 451ms, stddev = 162ms
A:LAB-PE4-SR# ping 192.168.20.5
PING 192.168.20.5 56 data bytes
64 bytes from 192.168.20.5: icmp_seq=1 ttl=62 time=85.1ms.
64 bytes from 192.168.20.5: icmp_seq=2 ttl=62 time=13.9ms.
64 bytes from 192.168.20.5: icmp_seq=3 ttl=62 time=14.6ms.
64 bytes from 192.168.20.5: icmp_seq=4 ttl=62 time=14.9ms.
64 bytes from 192.168.20.5: icmp_seq=5 ttl=62 time=13.8ms.

---- 192.168.20.5 PING Statistics ----
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min = 13.8ms, avg = 28.5ms, max = 85.1ms, stddev = 28.3ms
A:LAB-PE4-SR#


3. Reference


  1. Glenn, Amin. 2011. Alcatel-Lucent network routing specialist II (NRS II) self-study guide preparing for the NRS II certification exams. Indianapolis: Wiley
  2. Juniper Techlibs. 2015. Example: Configuring Multi-Level IS-IS. 21 Jan (http://www.juniper.net/techpubs/en_US/junos14.1/topics/example/isis-multi-level.html) 
  3. Mobeen Tahir, Mark Ghattas, Dawit Birhanu, Syed Natif Nawaz. 2009. Cisco IOS XR Fundamental. Indianapolis: Cisco Press
  4. rfc1142 - OSI IS-IS Intra-domain Routing Protocol
  5. rfc1195 - Use of OSI IS-IS for Routing in TCP-IP and Dual Environments
  6. rfc1629 - Guidelines for OSI NSAP Allocation in the Internet










No comments:

Post a Comment